Page 1 of 1

P64 Trigger works fine until top slide on pistol

Posted: April 23rd, 2018, 11:13 am
by Paul42
Hi all,
I wonder if you can help.
My pistol has been stripped and cleaned completely
When the top slide is off my P64 the trigger works fine. When the top slide is in place, the double action seems to 'disconnect' mid trigger pull.
I have cleaned and re cleaned and assembled to no avail.
This is a century arms piece, and needed a new safety, which i later got, that said, the trigger function has always been as described.
Any ideas as to the problem?
I am at my wits end with it, my next recourse is to sell it as a parts pistol.
Hopefully it will not come to that, but i will consider offers as well.

Re: P64 Trigger works fine until top slide on pistol

Posted: April 23rd, 2018, 2:01 pm
by Ketchman
Does the trigger work in single action mode? And does the safety also work as it is supposed to?

Re: P64 Trigger works fine until top slide on pistol

Posted: April 23rd, 2018, 9:56 pm
by Weasel640
Your problem is going to lie in how the Disconnector interacts with this new Safety. In short the Disconnector is doing what it is supposed to do at the wrong time e.g. Disconnect the Trigger Bar from action. At a normal state of rest the Safety sits above the Disconnector. If you search the forums there are threads about fitting the Disconnetor to you gun, normally for a new Disconnector. Be careful removing a little material on the Disconnector can go a long way.

Re: P64 Trigger works fine until top slide on pistol

Posted: April 25th, 2018, 3:49 pm
by Paul42
I think it is the Disconnetor, not wanting to shave material from it, may buy a replacement and see how that goes. In single action (hammer back) it functions fine, and the safety works as it should.

Re: P64 Trigger works fine until top slide on pistol

Posted: April 25th, 2018, 10:02 pm
by Weasel640
Paul42 wrote:
April 25th, 2018, 3:49 pm
I think it is the Disconnetor, not wanting to shave material from it, may buy a replacement and see how that goes. In single action (hammer back) it functions fine, and the safety works as it should.
Sounds like a plan. That way you have another one if you take to much off. I just checked too. Disconnectors are still available for about $15 plus shipping. So much easier to come by than Safeties.

Also in the mean time post a pic for the rest of us. Just looking in the inside of the Slide where the Safety sits with the track/rails of the Slide around it. One pic with the the Safety on and one of it off. That way we can check that everything lines up right.