Issues with slide and mag eject

Mods and Fixes by P-64 users...
Post Reply
xXPerfecto
Posts: 4
Joined: February 17th, 2011, 5:38 pm

Issues with slide and mag eject

Post by xXPerfecto » February 17th, 2011, 6:06 pm

OK i have a polish p-64 1974. if i put an empty mag in the pistol and pull the slide back it locks in place. thats fine. but it takes everything i have to get the mag out. when i put the mag back in and pull the slide back it locks in place and will not move. the pistol works fine with no mag in. someone please help. i can post pics if that helps.

thanks
Justin

User avatar
normsutton
Global moderator
Global moderator
Posts: 3558
Joined: February 26th, 2006, 6:59 am
Location: LAKELAND FL.
Contact:

Re: Issues with slide and mag eject

Post by normsutton » February 18th, 2011, 7:45 am

Justin

sounds like the wrong mag, pix should help

NORM
NORMSUTTON@AOL.COM
N.R.A. LIFE MEMBER 1976

ImageImage

xXPerfecto
Posts: 4
Joined: February 17th, 2011, 5:38 pm

Re: Issues with slide and mag eject

Post by xXPerfecto » February 18th, 2011, 8:05 am

i almost sure there the right mag. i have two mags and the problem is with both. i think there might be a issue with the slide stop spring. but i have no idea where to begin. the slide lock leaver is getting stuck in the wrong postion. (i think). ill post pics of the issue and the mags when i get home later Edit: i have some now but not of the jam. Image

User avatar
normsutton
Global moderator
Global moderator
Posts: 3558
Joined: February 26th, 2006, 6:59 am
Location: LAKELAND FL.
Contact:

Re: Issues with slide and mag eject

Post by normsutton » February 19th, 2011, 8:24 am

Justin
ok, seem to be the right mags, you cleaned the gun right of all cosmoline,

NORM
NORMSUTTON@AOL.COM
N.R.A. LIFE MEMBER 1976

ImageImage

xXPerfecto
Posts: 4
Joined: February 17th, 2011, 5:38 pm

Re: Issues with slide and mag eject

Post by xXPerfecto » February 19th, 2011, 9:25 am

i started on that last night. i will post back with the results

thanks
Justin

xXPerfecto
Posts: 4
Joined: February 17th, 2011, 5:38 pm

Re: Issues with slide and mag eject

Post by xXPerfecto » February 21st, 2011, 4:23 pm

WOW.... :D that did the trick... im kinda a noob with the old guns

thanks for all the help...

User avatar
blinddog
Veteran member
Veteran member
Posts: 739
Joined: April 17th, 2007, 1:22 pm
Location: Roseburg, Or.

Re: Issues with slide and mag eject

Post by blinddog » February 27th, 2011, 5:11 pm

A clean pistol is a good pistol!

Post Reply